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Unit 8: Introduction to Database 
 

Introduction 
 

A database is an organized collection of data. This unit describes the 
basic concepts of database, Database Management System, advantage of 
Database Management System, Application of Database Management 
System.  In this unit you will be familiar with Microsoft Access database. 
 

Lesson 8.1: Understanding Database, Database 

Management System   
 

Learning Objectives 
On completion of this lesson you will be able to learn: 
 
� about Data and Database. 
� about Database Management System. 
� objective of Database Management System. 
� purpose of Database Management System. 
� applications of Database Management System. 
� function of Database. 
� access Database Files. 
 

8.1.1 Data 
Generally, pieces of information are called data. In computing, data is 
also information but that has been translated into a form which is more 
convenient to manipulate or process by the computer. 
 

8.1.2 Database 
A database is a collection of data or information that is organized in such 
a manner so that it can easily be accessed, managed, updated and 
retrieved. Computerized databases are much more powerful than non-
computerized databases because users can easily search and reorganize 
data in hundreds of ways. As for example- the telephone index of a non-
computerized database contains names, addresses, and telephone 
numbers arranged alphabetically by last name so that it is easy to find 
information for a particular person but in computerized database, you 
could search by address, first name, or phone number, instead of just by 
last name. 
Oracle, Microsoft SQL server, Sybase, DB2, DB2-UDB, Informix are 
the examples of commercial databases management system. MySQL, 
PostgreSQL, Predator are some free database management system. 
 
How database is different from word-processors and spreadsheets? 

• Word-processor- Works with text, graphics. 

• Spreadsheets- Numbers, Data modeling, Statistical analysis. 
• Database-Use same data for many purposes. 
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8.1.3 Database Management System 
Database Management System (DBMS) is essentially a collection of 
interrelated data and a set of software programs (or group of programs) 
that provides storage, access, security, and other facilities of those data. 
From 8.1.2 we already know the collection of data is usually referred to 
as database .Database systems are designed to manage huge amount of 
data. The management of data involves both data definition and the 
manipulation of data. The DBMS acts as an interface between 
application programs and physical data files and provides tools to add, 
delete, display, print, search, select, sort, and update data. 
 

8.1.4 Objective of Database Management System 
 
The primary objective of DBMS is  

• To provide a convenient way to store data into a database.  

• To provide an efficient manner to retrieve data from database.  
 

8.1.5 Purpose of Database Management System 
In traditional file system each program has its own file, so too many files 
will be needed and there may be many redundant data that create 
inconsistency. Database Management System removes these 
disadvantages. The DBMS permits an organization to centralize data, 
manage them efficiently, and provide access to stored data by application 
programs. Database Management System can store data one time and 
allow multiple programs to access those data. So data redundancy and 
inconsistency is removed in Database Management System. A major 
purpose of a database management system is to provide users with an 
abstract view of data. 
 

8.1.6 Applications of Database Management System 
 
Databases touch all aspects of our lives. 

• Human resources: Payroll. 

• Banking: Transactions. 

• Universities: Student information management system, library 
information system.  

• Sales: customers, products, purchases. 

• Manufacturing: inventory, orders, production. 
 

8.1.7 Advantages of DBMS 
� Find information quickly. 
� Performs complex retrieval and data manipulation tasks based on 

queries. 
� Data inconsistency and redundancy is reduced. 
� Restricting unauthorized users. 
� Providing backup and recovery. 
� Better service to the users. 
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� Create mailing list for mail merges. This allows the user to send out 
letters containing personal information kept in database. 

 
 

8.1.8 Database Management System Offers the Following 

Services: 
 

• Data Definition. 

• Data Maintenance. 

• Data Manipulation. 

• Data Display. 

• Data Integrity. 
 

8.1.9 Microsoft Access Database: 
 

 
    

• Database File: Database file is the main file that represents the 
entire database. Example: student.mdb 

• Table: A table is a collection of data about a specific topic. There 
can be multiple tables in a database. Example: student, employee. 

• Field: Each column represents as field. Each field in a table has a 
field name; appearing at the top of the column. Tables usually 
contain multiple fields. Example: studentid, studentname, are the 
field name of student table. 

• Record: Each row represents as record. For example, studentid, 
studentname fields make up a single student record.  

• DataType: Data types are the properties of each field. It indicates 
the type of data that each field can hold. A field only has one data 
type. For example text, number, date etc.  
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Exercise 
 
1.   Multiple choice questions  

 
a.   Pieces of information called  
 
i)   data 
ii)   database 
iii)   DBMS 
iv)   none of the above. 
  
b.  Accuracy of the data ensures. 
 
i)  data integrity 
ii)  data definition 
iii)      data manipulation 
iv)  data maintenance. 
 
c.   Which one is a free database system?  
 
i)  Oracle 
ii)  Microsoft SQL server 
iii)   Sybase 
iv)    MySQL. 
 

2.    Analytical questions 

 
1. What is database? 
2. What is DBMS? What are the primary objectives of DBMS? 
3. Discuss the services offer by the DBMS. 
4. Discuss the purposes of DBMS.    
5. What are the advantages of DBMS? 
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Lesson 8.2:  Getting Familiar with Microsoft 

Access for Windows 
 
Microsoft Access is a database software package. With Access you can 
create a computerized database. For example, you can use Access to 
organize the students who attend in a school, the courses they registered, 
and the instructors who teach them. After you create an Access database, 
you can search it, manipulate it, and extract information from it. Dear 
learners, this lesson introduce you to Access windows and teach how to 
create Access database. 
 

Learning Objectives 
On completion of this lesson you will be able to learn: 
 
� access database objects. 
� how to run Microsoft Access. 
� crating database. 
 

8.2.1 Microsoft Access Database Objects 
The Objects bar lists the major types of objects in an Access database. 
Objects are as follows. 

• Tables 

• Queries 

• Forms 

• Reports 

• Page 

• Macros 

• Modules. 
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Objects 

Tables In Access, data is stored in tables. A table is a set of columns and 
rows, with each column referred to as a field. Each row of a table is 
referred to as a record. Each value in a field represents a single type 
of data.  

Queries Queries used to retrieve specific data from database and to answer 
questions about your data. For example, you can use a query to find 
the names of the employees in your database who live in a particular 
district. 

Forms Forms give the ability to choose the format and arrangement of fields. 
You can use a form to enter, edit, and display data. 

Reports Reports organize or summarize data so that you can print it or view it 
on screen. You often use reports when you want to analyze your data 
or present your data to others. 

Macros Macros give you the ability to automate tasks. You can use a macro to 
add functionality to a form, report, or control. 

Modules Like macros, modules give you ability to automate tasks and add 
functionality to a form, report, or control. 

 

8.2.2 Starting Microsoft Access 
Dear learners let us follow any one of the following way to start 
Microsoft Access 
  
To start Microsoft Access: 
Use the start button on the task bar to open run then type msaccess then 
press enter  
 

        
 
 
Or 
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Use the Start button on the task bar to open: Programs -> MS Office -> 
Microsoft Access  
 
Or 
Double click on the Microsoft Access icon on the desktop. 
 

  
 
Once Access is running an initial screen will be displayed and it looks as 
follows: 
 

      
 

To exit Access, pull down the File menu and select the Exit menu item.  
 
Or 
You can click the cross( X ) at the top right corner of the window. 
 

8.2.3 Creating Database  
To create new databases choose Blank Database from "Task Pane" 
appear on the right-hand side of the screen and specify a new file name 
for the database. Use a descriptive name for the new database. Click on 
the OK button to create the new database. 
 
To open an existing database choose open an Existing Database from 
"Task Pane" appear on the right-hand side of the screen, select More 
Files then navigates to the drive, highlight the existing database file on 
disk and click the open button to open the database. 
 



Office Automation and MS Office 

 

 213

To create a new database in Access   
1. From the menu choose File -> New. 

2. The "New File" Task Pane will appear on the right-hand side of the 
screen. 
 

 
3. Click the option "Blank database” which will then ask you to name 

your database.  Access databases are saved with the .mdb extension.  

4. Name your file (we chose sst) and press Create. This will 
automatically save your blank database as sst. 

 

 
 

5. The Access Database interface should now be displayed and you are 
ready to learn Access. 

 
 
Now the database has been created. We can begin to create Access 
table.  
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Exercise 
 
1.   Multiple choice questions  

 
a.   Table is a set  
 
i)   columns  
ii)   rows 
iii)   columns and rows 
iv)   field. 
  
b.   File extension of Microsoft Access database  
 
i)  .mdb 
ii)  .dbf 
iii)   .txt 
iv)  .exe 
 
c.   The core component of database is  
 
i)  table 
ii)  form 
iii)   report 
iv)  query. 
 

2.   Analytical questions 

 
1. Discuss about the objects of Microsoft Access database. 
2. Discuss the steps to create a database. 
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Lesson 8.3: Inserting Data to Database  
 

Learning Objectives 
On completion of this lesson you will be able to learn: 
 
� data types. 
� crating new tables. 
� modifying tables. 
� adding records. 
� editing records. 
� save records. 
� deleting records. 
 

8.3.1 Understanding Data Types 
Data type determines the type of information that may be entered in that 
field. A field with a data type of text can store alphabetic characters and 
numbers. Generally you cannot perform mathematical calculations by 
using a text field. For example, you can use a text field to store a street 
address. Unless you do some manipulation, you cannot use the numbers 
in the street address in mathematical calculations. You will not able to 
sum or average the numbers in an address field. Alternatively, you can 
assign a Test Score field a data type of Number. You can enter numbers 
into the field and then average, sum, or perform other calculations with 
the numbers. However, you cannot enter an alphabetic character in a 
number field. 
 

Data Types 

Data Type Use Notes 

Text Alphanumeric data. Use for text and for 
numbers that are not used in mathematical 
calculations. Use for names, addresses, 
and other relatively short pieces of text. It 
can store up to 255 characters. 

 

Memo Long text. Use for long pieces of text, 
such as notes and long descriptions. Can 
store up to 64,000 characters. 

  

Number This field is used for numbers where you 
want to add, subtract, multiply, divide, 
average, and do numerical calculations.   

 

Date/Time Use for dates and times.   

Currency Use for currency like Dollars ($) Prevents 
rounding 
during 
calculation 

AutoNumber Unique sequential numbers or random 
numbers automatically inserted when you 
create a record. Use to create a primary 
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key. 

Yes/No Logical data. Use when only one of two 
values is valid. Yes/No, True/False, etc. 

  

Hyperlink Use to store hyperlinks.   

Attachment Use to store attachments.   

OLE Object OLE means "Object Link Embedding" 
which indicates you can insert a graphic, 
picture, sound, word document, Excel 
spreadsheet, power point presentation  
etc.  
 

  

 

8.3.2 Tables 
A table is a set of columns and rows. Each column is called a field. 
Within a table, each field must have a name and no two fields can have 
the same name. Each value in a field represents a single category of data. 
For example, a table might have three fields: employee id, Name, and 
Phone Number. The table consists of three columns: one for employee 
id, one for Name, and one for phone number. In every row of the table, 
the employee id field contains the employee id number, the Name field 
contains the employee name, and the Phone Number field contains the 
phone number of the employee. Each row in a table is called a record. 
 
 
Example: 

 
 

 
                 
   Record 
 
 
 

Here the employee table has 3 columns (Employee id, Name, Phone 
Number) and 2 rows or records of data.  

 

8.3.3 How Data is organized in Tables?  
Tables organize data into columns (called fields) and rows (called 
records). For example, each field in a Products table contains the same 
type of information for every product, such as the product's name. Each 
record in that table contains all the information about one product, such 
as the product's name, supplier ID number, units in stock, and so on. 
 

8.3.4 Creating Microsoft Access Tables 
Tables are the foundation of an Access database. Access stores data in 
tables. How to create a table, add fields to a table, assign data types to 
fields, and set field properties have been discussed in this section. 

Employee   

Employee id Name PhoneNumber 

001 Labib 01716115139 

002 Babul 01717224501 

Field 

Table Name 

Record 
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Creating a Table  
To create Access table you can follow any of the three instructions 
below: 

• Create a table in Design view, where you can add fields, define how 
each field appears or handles data, and create a primary key.  

• Use the Table Wizard to choose the fields for your table from a 
variety of predefined tables such as products, employees, suppliers, 
order details. 

• Entering data directly into a blank datasheet. When you save the new 
datasheet, Microsoft Access will analyze your data and automatically 
assign the appropriate data type and format for each field.  

 

Create a Table in Design View 
Creating a new table in design view requires the following steps:  
 

1. In the Database window click on the Tables tab     under 
Objects on the Access main screen. 

2. Click on the new button.  

3. Choose the Design View and click the OK button.  

4. Define each of the fields in your table. 

5. Click in the Field Name column and type a unique name for the 
field. 

6. In the Data Type column keep the default (Text) or click in the Data 
Type column, click the arrow, and select the data type you want.  

7. In the Description column, type a description of the information this 
field will contain. This description is displayed on the status bar 
when adding data to the field and is included in the Object Definition 
of the table. The description is optional.  

8. To set the property of a field click the field whose property you 
want to set. General tab which appears lower portion of the 

window contains field property like FieldSize, Format, Input 

mask, Caption, Default Value, validation Text etc. FieldSize- 

You can enter maximum number of characters in the field. 

Default Value- You can enter a value automatically for new 

records. Format- Display layout for the field. 

9. Designate a primary key by clicking on one of the fields that you 
want to define as primary key with the right mouse button and then 

choose Primary Key    from the pop-up menu.  

10. Save the table by pulling down the File menu and click Save.  
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11. Close the new table by pulling down the File menu and click close.  
 
Dear learner you don't have to define a primary key, but it's usually a 
good idea, if you don't define a primary key; Microsoft Access asks if 
you want to create one for you when you save the table.  
 

        
 

  

        
 
 

Create Table by Using the Table Wizard 

Creating table by using table wizard is a quick way to create a database.  
Creating new table by using the table wizard requires the following 
steps:  

1. Click Tables tab  under Objects, and then click New on the 
Database window toolbar.  

2. Double-click Table Wizard.  

3. Follow the directions in the Table Wizard dialog boxes. 
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Note   If you want to modify or extend the resulting table, you can do so 
in Design View. In Design View, you can create new database objects 
and modify the Design View existing ones. 
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8.3.5 Opening Existing Table 

1. In the Database window, click Tables  under Objects.  

2. Click the table you want to open.  

3. Do one of the following:  
 

• Click Design on the Database window toolbar to open the table 
in Design view. 

• Click Open on the Database window toolbar to open the table in 
Datasheet view. 

 
To change the structure of an existing table (modify, add or delete 

fields) 

Follow the given instruction below to change the structure of an existing 
table: 

1. Click on the Tables tab  on the Access main screen  

2. Highlight the name of the table to be modified and click on the 
Design button.  

3. Make the necessary changes.  

4. To add a field select the fields where you want to add then click right 

mouse button and choose insert rows   from the popup menu 
and type a unique name for the field Name column. 

5. Select the field that you want to delete then click right mouse button 

and choose delete rows   from the popup menu  

6. Save the table by pulling down the File menu and choosing Save.  

7. Close the table by pulling down the File menu and choosing Close.  
 
After creating a table you can insert data into it. Access assigns data type 
to each field based on your entry. Your can enter data by typing in each 
field. 
 

8.3.6 Entering Data to a Table 

Data can be inserted, deleted or modified in tables using a simple 
spreadsheet-like display. To bring up this view of a single table's data, 
highlight the name of the table and then click on the Open button. In this 
view of the table, shown in the figure below, the fields (columns) appear 
across the top of the window and the rows or records appear below. This 
view is similar to how a spreadsheet would be designed.  

 

Insetting, Editing or Deleting Record 

Insert or edit data in datasheet  
Open datasheet. 
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To add a new record, click New Record  on the toolbar, type the 
data, and then press TAB to go to the next field. At the end of the 
record, press TAB to go to the next record.  
 

To edit data within a field, click in the field you want to edit, and 
then type the data.  

Dear learners, if you want to correct a typing mistake, press 
BACKSPACE. To cancel your changes in the current field, press ESC. 
To cancel your changes in the entire record, press ESC again before you 
move out of the field. When you move to another record, Microsoft 
Access saves your changes.  

 
 
Note: at the bottom of the window the number of records is displayed. In 
this case, since the table was just created, only one blank record appears.  
 
To add data to the table, simply type in values for each of the fields 
(columns). Press the Tab key to move between fields within a record. 
Use the up and down arrow keys to move between records. Enter the data 
as given below: 
 

 
 
 
 
 
 

 

Employee id Name Phone Number 

004 mamun 01716115139 

005 alim 01718353366 

006 sharif 01728516824 
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To use keys to move around a table: 
 

Key to Press Action 

Tab Moves to the next field to the right. If you are in the last field in a 
record, moves you to the next record. If you are in the last record in 
a table, creates a new record. 

Left-Arrow Moves to the next field to the left. If you are in the first field in a 
record, moves you to the previous record. 

Shift+Tab Moves to the previous field. If you are in the first field in a record, 
moves you to the previous record. 

Right-Arrow Moves to the next field. If you are in the last field in a record, 
moves you to the next record. If you are in the last record in a 
table, creates a new record. 

Up-Arrow Moves you up one record. 

Down-Arrow Moves you down one record. 

Ctrl++ Creates a new record. 
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To use the Navigation bar to move around a table: 
 
 
 
 

  

. 

 1 Go to First Record 

2 Go to Previous Record 

3 The Current Record 

4 Go to Next Record 

5 Go to Last Record 

6 Create a New (Blank) 
Record 

 
To modify existing data, simply navigate to the record of interest and tab 
to the appropriate field then change the existing data.  
 
To delete a record, first navigate to the record which one you want to 
delete. Then pull down the Edit menu and choose Delete record and click 
on it.  
 
To close the table and return to the Access main screen, pull down the 
File menu and choose the Close menu item.  
 

Delete a Record 

 
1. Open a datasheet. 
2. Click the record you want to delete.  

3. Click Delete Record   on the toolbar.  
 
Save a Record 

 
Microsoft Access automatically saves the record when you are adding or 
editing as soon as you move the insertion point to a different record, or 
close the form or datasheet you are working on.  
 
To explicitly save the data in a record while you are editing it, click Save 
Record on the Records menu.  

1 2 3 4 5 6 
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Exercise 
 
1.   Multiple choice questions  

 
a.   Which one is the foundation of an Access Database?   
 
i)   tables  
ii)   forms 
iii)   queries 
iv)   none of the above. 
  
b.  Memo data type can store  
 
i)  up to 64,000 characters 
ii)  up to 44,000 characters 
iii)       up to 60,000 characters 
iv)  up to 6,000 characters. 
 
2.    Analytical questions 

 
1.     Discuss about data types. 
2.     Write down the steps to create a new table in design view. 
3.     Write down the steps required to change the structure of an   

      existing table. 
4.     How you can enter data to a table.   
 
Hands on Practice 

1. 

a)  Create a database and save it as sst  

b)  Create a table containing 3 columns and 5 rows and insert 5 

records. 

c)  Save the table as bou. 

d)  Select the 3 rd record. 

e)  Delete 2nd record. 

f) Select 1 st record. 

g)  Create blank (new) record. 

 

 

 

 


