
Part 1 - Introduction

Find a photo of an object or scene that you want to use as a your CameraMap. Try to get a
scene with as few overlapping objects as possible.

Using an image editing program, clean as many overlapping obstructions (people, wires,
poles) off areas that you will be projecting on to geometry.

A cloning tool is very handy for this job.

This is because objects that are in the foreground will get projected onto background
objects as well....



..instead of onto seperate geometry built especially for them.

Determine what your final output resolution is. For this tutorial we will be  rendering out at
720 x 486 (NTSC).

Once your output resolution is decided, pad your source image to the same aspect ratio with
an image editing program.

Do note that if you decide to render at a smaller size, you will have to keep the same aspect
ratio. This is because CameraMaps have to have the same aspect ratio as the output
rendering size.

Even 'rounding' the output size to a whole number when rendering smaller can cause
distortion that makes detailed alignment impossible.



Pad the tops and bottoms of your image with black space so it is the same aspect ratio as
your render resolution.

You can rotate the image. This serves two purposes.

  1) It reduces how much disk drive space the file uses.
  2) It allows a higher amount of detail in the Camera Window when lining objects up.

  This is how the file in this tutorial was set up.



Part 2 - Set up the Camera

This tutorial is going to use the convention of one Electric Image unit equating to 1
foot.Since this is a project that is based on real world objects, it will be easier to think of
measurements this way.

Launch Electric Image and create a new project.

In the Render Control window (Cmd-R), change the current settings to your output
resolution and pixel ratio.

Do note that if you decide to render at a smaller size, you will have to keep the same aspect
ratio. This is because CameraMaps have to have the same aspect ratio as the Output
Rendering size.

Even 'rounding' the output size to a whole number when rendering smaller can cause some
distortion. This is why it is so important to determine your output size before you start your
project.



In the Project window (Cmd-L).Rename your Camera to something so you'll be able to
differentiate it from other cameras later.

Select the Background CameraMap Camera and Get Info (Cmd-I or double click) on it. In
the FOV tab, set the Field of View to the same as that of the camera that you took the
source photo with.

Check the Show Angle box. This will help you to visualize how the texture is going to be
projected onto the geometry.

It might be helpful if you imagine that the four corners of the angle box are the four corners
of your texture as it is being projected out from the the camera.

In the FOV tab, set the Field of View to the same as that of of the camera that you took the
source photo with. Since we are going to be using the rotated image as our projected
texture, the Focal Mode will be set to Horizontal .

Be aware that by using a zoom on a camera will change your field of view and focal length.
(Check the manual of your camera for information on any lens settings it might have).



Since the texture is rotated, we have to roll the camera so it will be aligned with the model.
In the X-Form Tab of the Background CameraMap Camera, change the Roll to -90. This
rolls the camera into the same position as the projected CameraMap.

Let's move the camera to the origin and the reference to someplace to the north (positive Z)
of it. It saves us the headache of having to cross the positive/negative line and adding the
amounts of both sides.

We also want to use as many known values as we can when we are lining things up later,
so lets put the camera at the same height as when it was taken. So the Y value goes to 6
(the photographer is 6 feet tall.)

We don't know the exact point at which the camera was looking so we'll just put the 'Y'
value of the Reference Point at the same value as the Camera.



In the Projection Map Tab of the same Camera Info window, click on the Add button and
select the texture map that you are going to apply to your geometry.

Double Click on the CleanBG texture. This brings up the Texture Info window. In the
Projection Tab, change the Tiling type to None for both X and Y.

Since this is a projection map, we do not want the texture to be repeated onto objects
unnecessarily.

Close the Dialog.



Now you can see the image as it will be projected from the Camera in the Camera View
window. Click on the Color Bar button and select Camera Projection "CleanBG".

Since the texture map has an alpha channel the image looks a little strange. This is easily
corrected. If the size of your image is large, this might take a while for it to interpolate to
the size of your camera window. Don't worry, the program hasn't crashed.



Hold down the option key on your keyboard and click on the Color Bar button in the
Camera View window. Select RGB Only as this is all we want to see.

Much better.

Part 3 - Set up the Geometry

Just to show how easy and powerful this feature is, we are going to use nothing but a
Standard Shape plug-in for the geometry.

Under the File menu, Add > Socket > Standard Shape and give your Cube the attributes
shown to the below.

We are going to use 1 as our initial value for all three axis.



Rename the Standard Shape Group to Alley Walls so we can differentiate it from other
objects later on.

Since most textures applied with CameraMaps are going to already have their own lighting
(ours do) the default is set to Lumanence. Therefore, you can delete the Light 1 object.

Since we sometimes don't know the exact dimensions of an object taken in the real world,
we will have to guess a little.

Put these initial guesses into the scale values of the Alley Walls object. Since we used 1 as
the original size of the cube, the cube is now 80 feet wide, 100 feet tall and 1500 feet long.



Open up the Linkage window for the Alley Walls object (Cmd-Option Double Click or
Linkage under the Tools menu).

From the Link Alignment Position: popup, select Bottom. This will force the center of the
object to the bottom. You'll notice that the Y position went to -0.5. This is because the
object is only 1x1x1.

While we are here. Let's go ahead and put the Center down in the corner. This will make it
easier to manupulate later. So in the X and Z Position put 0.5.

The indicators should look like this if your view is from the Front.



Now that the Center point is set correctly, in the Group Info window for the Alley Walls
object set the Y value to 0. Now the ground is at ground level.

Part 4 - Create and Apply Selection Sets

Now that we have geometry to apply a texture, it's time to set up the link between them.
CameraMaps are applied using the Selection Set feature.

With the Alley Walls object selected (this is very important for the next step), go to the
Select menu and choose: By Set  > Edit Sets.



The Edit Sets window appears.

Under Selection Sets Click the Add button. Type in Walls Set and hit OK. This new set
now appears in the list below.

Now you want to add objects to the set. Select the Walls Set' from the Selection Sets side
of the window and hit the Add button from the Members side.

This added the Alley Walls object to the Walls Set Selection Set.

Close the dialog.

In the Projection Map tab of the Background CameraMap Camera Info window, select the
CleanBG map you added earlier.

In the Camera Map Applied To: popup select the Walls Set you created earlier.

You now have linked the CameraMap projected from your camera to the Alley Walls
object. You can now close the Camera Info window.



Part 5 - Lining the Camera to Geometry

The problem with rotating the projected texture is that it creates a little bit of confusion
when lining things up. If you just remember that when you are actually moving the camera
to the 'Right', it appears that it is moving 'Up' in the Camera View window. Here is a little
compass that might help you when you are trying to line things up



A couple of things you can do to avoid moving things accidentally is to lock the Alley
Walls object in the Project window.

Something else you can do to keep things lined up is to use the constrain tool.

It's time to start lining up. Move the camera reference point until the lower right of the
alleyway (Top Right in the Camera Window) corner is lined up with the photograph.



After moving the position of the Camera Reference Point, and moving the camera to the
right a little (but NOT up or down) the bottom right corner is lined up.

You'll notice that the left and top parts of the alley are off still by a little bit.

 (The settings for a lined  up corner are below)



So it's back to the Group Info window of the Alley Walls object to make minor scale
adjustments to fit the object to the scene.



Part 6 - Creating and Rendering from a Secondary Camera

Now the fun part.

Add a camera under the File menu: Add > Type > Camera.

Put the camera in the middle of the Alley Walls cube. It's default view is to look back at the
origin, so select and move the reference point to look at the back wall that the Background
CameraMap camera is looking at.



Select the Camera View window if it isn't the foremost window (Cmd-4 ).

Hold down the option key on the keyboard and click in the title bar of the Camera View
window. This brings up a list of the available cameras. Select the Camera 2 that you just
added.



Do a couple of test renders from different places within the box.

Some settings for a good first render.

The black areas in some of the renders are places where the original texture ran out. You
will have to avoid using these areas with by careful placement of your camera.



Notice how the effect works best from around the original camera. This is because the
texture has the least amount of stretching across large areas.

As the camera gets closer to the end of the alleyway, the floor and walls start to get more
and more blurred. This is because the pixels are getting smeared across many pixels.



Part 7 - Creating a Second CameraMap

Now that the main part piece of geometry has been textured, we'll proceed to adding the
people back in that were deleted in the initial clean up of the original photo.

Since the people were taken by the same camera as the one that took the alley way, we'll
just Duplicate under the Edit Menu to make a copy of the Background CameraMap and
rename it to People CameraMap.

Since we want to change the projected texture, in the Camera Info window of People
CameraMap, double click on the CleanBG texture (in the Projection Map tab). This brings
up the Texture Info window.



In the Image tab, click on the Replace Image... button and apply the People image that is
included with this demo and close the Texture Info window.

In the Camera View Window, make the new People CameraMap the active camera by
option-clicking in the title bar. Then option click in the Color Bar button and select Alpha
Only. You should now see whats in the example below.

Part 8 - Creating and Lining Up More Geometry

Now we'll add a person and line him up with the projected texture. Create a Standard
Shape plane object with 6 width, 2.5 length.

In the Project window rename the Standard Shape to Person 1



Like we did before, change the Link Alignment Position to Bottom in the Link window.

Also in the Person 1 Group Info window.Change the Y Position to 0 so it 's bottom is at
ground level.

With the Camera View window visible, move the Person 1 object in the Top View window
until the object's bottom aligns with the outline of the person most right in the scene (top
most in the Camera view window) as you see below.

If you can't see so well what's happening in the Camera View window, increase the size of
the window, the map will show more resolution.

As a position for alignment try: X=26.163  Y=0  Z=121.53



Part 9 - Creating a Second Selection Set

Now we need to create a Selection Set for the People CameraMap

With the Person 1 object selected (again this is important), under the Select menu, choose
Set > Edit Sets.

Selection Set  Add a Set called People Set, and Members Add the Person 1 object to that
set.

Close the Edit Sets window.

Now that the set has been created, we need to apply the texture to that set. Open the People
CameraMap Camera Info window. Select the People texture you replaced earlier and then
in the Camera Map Applied To: popup, select the People Set. The texture is now applied
to the geometry



Make your Camera 2 the active camera by option clicking in the title bar of the Camera
View window. Move that camera until it is looking at the People 1 object and down
towards the end of the alley.

Do a test render. You'll notice that the RGB information in the People map is showing
around the person we are adding.

Part 10 - Using a Clip Map

This can be fixed by going back to the People CameraMap Camera Info window. Add a
second copy of the People texture map.



Since the RGB information is being applied to the Lumanance channel. All we need from
this second copy of the texture is the alpha information (for a clip map).

Double click on the second People texture map. This will bring up the Texture Info
window.

In the Filter tab, select Alpha Only from the Use Channel: popup menu.

Close the Texture Info window.

With the second copy of the People texture still selected, select Clip  from the Camera Map
Applied As: popup menu. This applies the alpha channel of the People texture as a clip map
for the objects in the People Set.



Now, go back to the Camera Window, and do a test render. The person is now 'in' the
scene.

Part 11 - Adding More Geometry

Included with this tutorial is a file called Other People.FACT.

Add this model to the project. Select Seperate when the secondary dialog appears as we
do not want to add any heirarchy to this model.

Select the new people objects and under the Select menu choose, By Set  > Edit Sets.

Select the People Set and on the Members side of the dialog, Add them.



Now you can set up a camera animation with the 'Camera 2' object and do a fly through on
the scene. Have fun.

Part 12 - Q&A

Questions to ask yourself when you are preparing to use a CameraMap.

  Are there overlapping objects in the source image?

This is one of the most difficult things to deal with when using CameraMap. This is
because like a texture map, the overlapping object is going to be projected back into the
scene. Even if geometry is used to pick up the object, the projection will continue back
through.

 

  Where is the camera going to be?

The more perpendicular an object is to a projecting camera, the better. As a piece of
geometry comes more and more parallel to the angle of the projecting camera, the more
projected pixels will be sheared across large portions of geometry.



Just because there is information on a texture map, doesn't mean that it is going to appear
correctly.

This is a render taken from very close to the end of the tunnel. You can see how the face
that is very perpendicular to the camera projection is very clear while the parallel one is
smeared.

 

  What is the resolution of the source images?

Camera maps, while applied differently are like any other texture map. Resolution of the
original texture map greatly affects the outcome of what a final render is going to look like.

As an example, if your source image is NTSC (740x486) and your camera is moving
forward into the image, your texture is going to soften and blur due to the fact that fewer
and fewer pixels of your source image are going to be seen.

  What is the field of view (FOV) of the camera used to take the source image?

This is probably one of the most important question simply because if you have the wrong
FOV information and then line up your objects to those in the Camera Window and then
move the camera, the distortion is going to be wrong and the effect blown.

  What is your final rendering resolution?

CameraMaps MUST be the same aspect ratio as the final rendering resolution. This means
that if you are going to render at NTSC (720x486) all of you CameraMaps have to be at the
same aspect ratio (1 high to 1.5 wide).



You might ask yourself...

  My source texture is taken from a camera and doesn't have the
  same aspect ratio as my rendering resolution, what do I do?

Easy. Just pad the image with black, and you now have an image that fits. This allows you
to used the correct FOV in the camera window when you are applying the map to your
geometry.

  My source photo was taken portrait instead of landscape, what
  do I do?

Well, you can pad the image with black on the left and right, but instead you can also leave
the image turned on it's side and roll the camera into position.

   I can't seem to line up my objects in the Camera Window. What should I do?

Instead of lining up objects using ONLY the camera window. You can also use your
secondary camera to zoom in on objects and do nudging and touch ups.


